Duo Mobile Works Best on Up-to-Date Operating Systems!

Posted May 6th, 2019 at 11:22 am.

Effective July 28, 2019 Duo will end support for the Duo Mobile application for iOS 10 and Android 6. We encourage you to upgrade to the latest OS versions to help protect your devices from security issues and for the best Duo Mobile experience.

Push and app-generated passcode authentications will continue to function on Duo Mobile apps installed on devices running these out-of-date operating systems, but eventually you will no longer be able to install Duo Mobile from the Apple App Store or Google Play Store if you are running iOS 10, Android 6, or earlier. As always, SMS-delivered passcodes and phone callback authentication do not rely on the Duo Mobile app and Duo will continue to support these types of authentication for older devices.

While authentications will continue to function, we always recommend running the latest version of Duo Mobile on a supported operating system to maintain strong security and get access to the latest features and improvements.

Contact the Help Desk with questions: help@brynmawr.edu or 610-6526-7440.

Filed under: Announcements by Melissa Cresswell

Comments are closed.